Use this forum to post questions and issues for discussion related to Browning cameras.
By picdic
#354385
hopefully this is just an issue in their "cheaper" cams. I just bought a recon force advantage.
heading for the hills tomorrow to put my cams out. going through all my gear tonight, preparing for the trip. grabbed my strikeforce. just bought it last year. loaded it with brand new batteries a couple weeks ago. flip the switch on, it lights up, showing battery level(which says way lower than it should), and won't do anything else. also won't shut off, have to pop the battery tray to get it to power down. turn on again, now says a different battery level %. leave on, lights eventually go off, like it's shutting down, then it flashes back on, just showing power level, and still won't do anything else. keeps repeating this cycle. changed to brand new batteries again, and it says 86%, and still just keeps doing that cycle process.
kinda not happy right now. just bought the recon and have been raving about it, and now this BS. and not too thrilled about having to deal with CS, having read about not-the-best results with them.
don't even want to deal with the "use lithium batteries", "buy a different SD card", "ya-da-ya-da-ya-da" garbage. and from others' similar issues, I don't even want a replacement strikeforce. i'm not interested in a repeat performance followed by a repeat performance. starting to possibly regret giving them more of my $$ on ANOTHER of their cams.
Italian chamois

Nice clear photos in a fantastic setting.

A beautiful set of healthy looking twins! https:/[…]

Creek crossing

A video before rain raised the water level. The s[…]

I hooked the new camera up to a 9 amp/hr SLA and l[…]