Use this forum to post questions and issues for discussion related to Browning cameras.
#357075
Hi
new to forum and was hoping others may have come across the issue i have. I have 6 Recon Force Advantage cams, 3 work perfectly the other 3 i have issues with. Now what im experiencing is when something triggers the cam it will then keep triggering another 5 to 7 times past that even when the animal is no longer in the area. I always do video and have set to 20 seconds, 1 second delay and ultra . Now clearly this isnt what they should do, but it happens every time the cameras are triggered, 1 vid with the animal and then another 5 to 7 vids of nothing. then it settles until its triggered properly again with an animal. and repeat

I have contacted browning about this and just waiting on a reply, dont fancy having to send my cameras to america tho from the UK. Now to add to the puzzle, when i first get the cams i test them i manually trigger them waving my hand in front etc and then leave a while trigger again etc, annoying thing is they work right when i do that. yet when out in the field nope they go into false trigger mode every time !!

so sending these back to where i got them is hard as the first time i did the store couldnt find anything wrong with them due to triggering them manually the same as i did lol.
Im hoping this is something a firmware update will fix when they do one but its annoying as all the false triggers are eating my batteries . I out of 70 vids i will only have 10 actual true triggers

other than this issue the vid quality is great although im not convinced on this 0.4 sec trigger considering some times slow moving animals are leaving the screen before it triggers,

any responses would be appreciated if you have come across this issue on any browning cameras and how it can be fixed

thanks guys :)

Kath
#357092
even tho no answers and loads of views lol, just wanted to update
had a response from browning and they have been really ace, they havent heard of this issue but have said its a prob so have asked for serial numbers and receipts. They have said they will send out replacements. so i dont think i have to ship the cams from UK to US which im thankful for !. But really happy with the customer support from them. So thankyou browning :)
#357099
If they were my cameras I would test them inside my basement/garage, so I could verify in a controlled environment any movement was from myself
Hyperfire 2 need opinions

Can someone please upload some photos here f[…]

With camera sharing the recipient does not need to[…]

Lithium Ion or Lithium Iron Phosphate batteries […]

OAN is Excellent! Real news. Tipping Point with Li[…]