Use this forum to post questions and issues for discussion related to all HCO and Spartan cameras. Note: Please post threads pertaining to cellular cams in the "Cellular Trail Camera Discussion" forum.
By wewilley
#356575
well just on the phone with spartan camera i have a SR 1 and need a new on off switch they dont sell any more i have to send the camera in i asked two things what would it cost and if i gave him the serial no. could he tell me if its still under warranty he said no on warranty and didn't know what the cost would be i asked if there was anyone there that could help me another no just a big wast of time
User avatar
By Anthony
#356592
I have these and you are welcome to them.

Two are go-cam 3G. One is a non-cellular called SR-1 maybe.... It works I am sure.

Do you want the SR-1? or all? One of the Go-Cam has some inside parts missing on it for some reason (main board and button and screen)

Under that go-cam on the left is that annual boat registration stuff that I hate to do. You can fill that out for me too if you like :mrgreen:
Attachments
0209191605a_HDR.jpg
0209191605a_HDR.jpg (122.78 KiB) Viewed 2189 times
0209191605_HDR.jpg
0209191605_HDR.jpg (104.95 KiB) Viewed 2189 times
0209191604_HDR.jpg
0209191604_HDR.jpg (161.25 KiB) Viewed 2189 times
User avatar
By LibbyLA
#356593
Is it the plastic switch that you move or is it the actual electrical switch underneath the plastic switch? If it’s the actual switch, that may have to be soldered.

What is or isn’t happening? You didn’t say.

If the camera won’t turn off or won’t turn on, try using some contact cleaner on the actual switch. With batteries out of the camera, take the four little screws out of the left side of the camera. You may want to use tape across the on/off switch and across the buttons to hold them to that front piece before you lift it off. Once you get the front cover off, spray contact cleaner in the on/off switch and move the switch back and forth very quickly several times. Let the contact cleaner dry before putting it back together. You can test it without putting the plastic cover back on to see if it turns on and off properly.

If that’s not what’s happening, then never mind. I’m just throwing that out there in case that’s the problem.
User avatar
By johnnydeerhunter
#356612
Try going to the link below and filling out the information there, you may get some more help this way. They may not want to give you a price until they get the camera and can diagnose the issue to be sure that it is just the switch.

https://www.hcooutdoors.com/support/warranty-rma.html
By UserName
#356725
Just changing the On/Off/SetUp switch? or whole main board :?:
User avatar
By Anthony
#356781
wewilley wrote: Sun Feb 10, 2019 11:40 am two things i live in NC Wilmington and yes on the sr1
liz im going to try the cleaner
Let me know how the cameras I sent you work out. I hope they work and they turned out to be 3G Spartan GoCams. You should be able to download the latest firmware and load that on. I assume there is a setting to run them as a stand alone camera. If so then they will function the same as an SR-1.

Let me know what you find. I see from the tracking that you did receive them. One of them had alkaline battery leak and the springs deteriorated. I suggest you get an external cable and just run that off 6V.
User avatar
By clarkengelman
#356786
Now thats how every company should treat there customer whether or not. Thanks . I always regret making a call to ask questions about my camera cause I usally get the run around.

I am hoping before July. We have had some planned[…]

Laying Down On The Job?

Must be Related

Or a Restaurant

Coyotes on the prowl

Yes they look big in winter then scrawny in summer[…]