Use this forum to post questions and issues for discussion related to Cuddeback cameras.
User avatar
By Mauri740
#362750
My C1 cuddeback has stopped working. I'm an electronic technician and I haven't problems to repair electronic boards. I found the faulty component that keeps the camera off. Now C1 turns on and does all functions , but still has a problem that makes it unusable. Now it becomes very difficult to fix it, I asked to cuddeback for the whole board but they replied that they do not ship any spare parts outside of their labs. I 'm sorry about this...I 'm very close to repair it. Do you have experience with cuddeback repair costs? Thank you
User avatar
By Mauri740
#362759
Hi Anthony, thanks for reply. I'm looking every day for non-working units, but seems that there isn't any unit available for spare parts.
User avatar
By Mauri740
#362829
Many checking hours for this camera trying to find the faulty component. The initial problem: a strong st-by current consumption, about 400mA instead of about 0.6 mA expected. The camera behaves unexpectedly and after about 1 hour the new battery pack is very hot and nearly to dead. After a difficult research, I found c71 leakage capacitor. The value of this capacitor is very critical. With many attempts I have found the right value which must be between 8 microfarads and a 10 microfarads. I found an 8.2uF SMD capacitor from an old electronic TV board and now the camera works very well. Hope that this note will be help to all those who have problems with this C1 Tcam.
We The People are fed up!

https://youtu.be/BXN9t2oo9gY

https://youtu.be/TevXuL4mGi8

Good start

For some reason this little guy catches my eye. I[…]

The New WorId Order!

https://youtu.be/Il5tj8F9l58