Trail Camera Discussion of Manufactured Cameras.
#356416
One of my trail cameras keep stopping dead. I usually fix it by soldering over corroded battery spring plate connectors but this time the camera would not start up again. So I decided to replace bad battery spring plate connectors for new ones.

I uploaded pictures in wrong order. First picture is at the bottom of this post.
Attachments
img_20190124_133958206.png
New Battery Spring Plate Connectors
img_20190124_133958206.png (574.62 KiB) Viewed 1520 times
img_20190124_125941061.png
img_20190124_125941061.png (553.82 KiB) Viewed 1520 times
img_20190124_131426071.png
img_20190124_131426071.png (624.97 KiB) Viewed 1520 times
img_20190124_131503593.png
img_20190124_131503593.png (482.25 KiB) Viewed 1520 times
img_20190124_132039517.png
img_20190124_132039517.png (602.6 KiB) Viewed 1520 times
img_20190124_132100478.png
img_20190124_132100478.png (648.74 KiB) Viewed 1520 times
img_20190124_132626123.png
img_20190124_132626123.png (596.74 KiB) Viewed 1520 times
img_20190124_132910171.png
img_20190124_132910171.png (490.86 KiB) Viewed 1520 times
img_20190124_133019670.png
img_20190124_133019670.png (513.29 KiB) Viewed 1520 times
img_20190124_133651608.png
img_20190124_133651608.png (624.31 KiB) Viewed 1520 times
Last edited by TrailCamGuy on Tue Jan 29, 2019 5:59 pm, edited 1 time in total.
#358349
Checked again and noticed leaks in the battery tray. Found out that the camera (based on the last time/date stamp) was dead for about 2 months. OOPS. I had to replace battery spring plate connectors again.
Attachments
img_20190912_171708179.png
img_20190912_171708179.png (200.66 KiB) Viewed 550 times
img_20190912_171819438.png
img_20190912_171819438.png (225.94 KiB) Viewed 550 times
img_20190912_173047946.png
img_20190912_173047946.png (211.54 KiB) Viewed 550 times
img_20190912_173916580.png
img_20190912_173916580.png (207.85 KiB) Viewed 550 times
#358355
I have had the same problems with alkaline batteries. I am thinking of only using Lithium batteries from now on. Has anyone had lithium batteries leak in their cameras? Last season I had two different cams using alkies leak and corrode all the connections.
#358358
csb wrote: Thu Sep 12, 2019 8:25 pm What are you using for batteries?
KODAK Super Heavy Duty ZINC. Not an issue as long I remember to check trail cameras every month.

I also have and use:
- Kodak XTRALIFE Alkaline
- Panasonic Alkaline Plus Power

I rarely use either Energizer or Duracell since (in my opinion) they are pricey.

Every stores I go to carry different batteries. I just buy whatever (big pack 18/20/24) on sale if possible.
#358362
Camoman1964 wrote: Fri Sep 13, 2019 9:45 am I have had the same problems with alkaline batteries. I am thinking of only using Lithium batteries from now on. Has anyone had lithium batteries leak in their cameras? Last season I had two different cams using alkies leak and corrode all the connections.
Never had lithiums leak. A couple cams I have set to just take pics I've left out year-round with no problems.
Just some latest videos

https://www.youtube.com/watch?v=cwSdb2V4PdM

Help me with my addiction!

Check with Verizon and see if you have texting on […]

I have a primos camera I run off a ext battery wit[…]

20190831_111807.JPG 20190831_111546.JPG Here is[…]